分类
在斐波纳契水平的策略

MACD指标有什么操作技巧?

通达信MACD箭头指标公式

SHORT:=13;LONG:=28;M:=8;
长短期价差:ema(CLOSE,SHORT)-Ema(CLOSE,LONG);
M日均线:EMA(长短期价差,M);
macd:(长短期价差-M日均线)*2,LINETHICK0;

stICKLINE((MacD > 0),0,MACD,2,0),COLOR0000CC;
STICKLINE((MACD > 0),0,MACD*0.9,2,0),COLOR0000EE;
STICKLINE((MACD > 0),0,MACD*0.8,2,0),COLOR0011FF;
STICKLINE((MACD > 0),0,MACD*0.7,2,0),COLOR0033FF;
STICKLINE((MACD > 0),0,MACD*0.6,2,0),COLOR0055FF;
STICKLINE((MACD > 0),0,MACD*0.5,2,0),COLOR0077FF;
STICKLINE((MACD > 0),0,MACD*0.4,2,0),COLOR0099FF;
STICKLINE((MACD > 0),0,MACD*0.3,2,0),COLOR00BBFF;
STICKLINE((MACD > 0),0,MACD*0.2,2,0),COLOR00ddfF;
STICKLINE((MACD > 0),0,MACD*0.1,2,0),COLOR00FFFF;
STICKLINE((MACD < 0),0,MACD,2,0),COLORCC0033;
STICKLINE((MACD < 0),0,MACD*0.9,2,0),COLOREE0033;
STICKLINE((MACD < 0),0,MACD*0.8,2,0),COLORFF1133;
STICKLINE((MACD < 0),0,MACD*0.7,2,0),COLORFF3333;
STICKLINE((MACD < 0),0,MACD*0.6,2,0),COLORFF5533;
STICKLINE((MACD < 0),0,MACD*0.5,2,0),COLORFF7733;
STICKLINE((MACD < 0),0,MACD*0.4,2,0),COLORFF9933;
STICKLINE((MACD < 0),0,MACD*0.3,2,0),COLORFFBB33;
STICKLINE((MACD < 0),0,MACD*0.2,2,0),COLORFFDD33;
STICKLINE((MACD < 0),0,MACD*0.1,2,0),COLORFFFF33;
VAR1:=3;
VAR3:=(3)*(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1)) - (2)*(SMA(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1),3,1));
DRAWICON(crOSS(VAR3,VAR1),0,1);

MACD技术学习

二、 MACD指标的计算方法
以EMA1的参数为12日,EMA2的参数为26日,DIF的参数为9日为例来看看MACD的计算过程
1、 计算移动平均值(EMA)
12日EMA的算式为:EMA(12)=前一日EMA(12)×11/13+今日收盘价×2/13
26日EMA的算式为:EMA(26)=前一日EMA(26)×25/27+今日收盘价×2/27
2、计算离差值(DIF)
DIF=今日EMA(12)-今日EMA(26)
3、计算DIF的9日EMA
根据离差值计算其9日的EMA,即离差平均值,是所求的MACD值。为了不与指标原名相混淆,此值又名DEA或DEM。
今日DEA(MACD)=前一日DEA×8/10+今日DIF×2/10
计算出的DIF和DEA的数值均为正值或负值。

三、 MACD指标的一般研判标准
MACD指标是市场上绝大多数投资者熟知的分析工具,但在具体运用时,投资者可能会觉得MACD指标的运用的准确性、实效性、可操作性上有很多茫然的地方,有时会发现用从书上学来的MACD指标的分析方法和技巧去分析黄金走势,所得出的结论往往和实际走势存在着特别大的差异,甚至会得出相反的结果。这其中的主要原因是市场上绝大多数论述技术分析的书中关于MACD的论述只局限在表面的层次,只介绍MACD的一般分析原理和方法,而对MACD分析指标的一些特定的内涵和分析技巧的介绍鲜有涉及。本节我将在介绍MACD指标的一般研判技巧和分析方法基础上,详细阐述MACD的特殊研判原理和功能。
MACD指标的一般研判标准主要是围绕快速和慢速两条均线及红、绿柱线状况和它们的形态展开。一般分析方法主要包括DIF和 MACD值及它们所处的位置、DIF和MACD的交叉情况、红柱状的收缩情况和MACD图形的形态这四个大的方面分析。
一、DIF和MACD的值及线的位置
1、当DIF和MACD均大于0(即在图形上表示为它们处于零线以上)并向上移动时,一般表示为处于多头行情中,可以买入或持有多单;
2、当DIF和MACD均小于0(即在图形上表示为它们处于零线以下)并向下移动时,一般表示为处于空头行情中,可以卖出黄金或持有空单;
3、当DIF和MACD均大于0(即在图形上表示为它们处于零线以上)但都向下移动时,一般表示为黄金行情处于退潮阶段,黄金将下跌,可以卖出黄金和观望;
4、当DIF和MACD均小于0时(即在图形上表示为它们处于零线以下)但向上移动时,一般表示为行情即将启动,黄金将上涨,可以买进黄金或持单待涨;

二、DIF和MACD的交叉情况
1、当DIF与MACD都在零线以上,而DIF向上突破MACD时,表明股市处于一种强势之中,黄金将再次上涨,可以加码买进黄金或持单待涨,这就是MACD指标“黄金交叉”的一种形式。
2、当DIF和MACD都在零线以下,而DIF向上突破MACD时,表明股市即将转强,黄金跌势已尽将止跌朝上,可以开始买进黄金或持单,这是MACD指标“黄金交叉”的另一种形式。
3、当DIF与MACD都在零线以上,而DIF却向下突破MACD时,表明股市即将由强势转为弱势,黄金将大跌,这时应卖出大部分黄金而不能买黄金,这就是MACD指标的“死亡交叉”的一种形式。
4、当DIF和MACD都在零线以下,而DIF向下突破MACD时,表明股市将再次进入极度弱市中,黄金还将下跌,可以再卖出黄金或观望,这是MACD指标“死亡交叉”的另一种形式。

三、MACD指标中的柱状图分析
在电脑分析软件中通常采用DIF值减DEA值而绘制成柱状图,用红柱状和绿柱状表示,红柱表示正值,绿柱表示负值。用红绿柱状来分析行情,既直观明了又实用可靠。
1、当红柱状持续放大时,表明黄金处于牛市行情中,黄金将继续上涨,这时应持单待涨或短线买入黄金,直到红柱无法再放大时才考虑卖出。
2、当绿柱状持续放大时,表明股市处于熊市行情之中,黄金将继续下跌,这时应持币观望或卖出黄金,直到绿柱开始缩小时才可以考虑少量买入黄金。
3、当红柱状开始缩小时,表明股市牛市即将结束(或要进入调整期),黄金将大幅下跌,这时应卖出大部分黄金而不能买入黄金。
4、当绿柱状开始收缩时,表明股市的大跌行情即将结束,黄金将止跌向上(或进入盘整),这时可以少量进行长期战略建仓而不要轻易卖出黄金。
5、当红柱开始消失、绿柱开始放出时,这是行情反转信号之一,表明上涨行情(或高位盘整行情)MACD指标有什么操作技巧? 即将结束,黄金将开始加速下跌,这时应开始卖出大部分黄金而不能买入黄金。 反之亦然。
第三节 MACD的特殊分析方法――形态分析
1、 M头W底
当MACD的红柱或绿柱构成的图形双重顶底(即M头和W底)、三重顶底等形态时,也可以按照K线图形态理论的研判方法来加以分析研判。
2、 顶背离和底背离
MACD指标的背离就是指MACD指标的图形的走势正好和K线图的走势方向正好相反。MACD指标的背离有顶背离和底背离两种。
(1) 顶背离
当黄金K线图上的黄金走势一峰比一峰高,黄金一直在向上涨,而MACD指标图形上的由红柱构成的图形的走势是一峰比一峰低即当黄金的高点比前一次的高点高、而MACD指标的高点比指标的前一次高点低,这叫顶背离现象。顶背离现象一般是黄金在高位即将反转转势的信号,表明黄金短期内即将下跌,是卖出黄金的信号。
(2) 底背离
底背离一般出现在黄金的低位区。当黄金K线图上的黄金走势,黄金还在下跌,而MACD指标图形上的由绿柱构成的图形的走势是一底比一底高,即当黄金的低点比前一次低点底,而指标的低点却比前一次的低点高,这叫底背离现象。底背离现象一般是预示黄金在低位可能反转向上的信号,表明黄金短期内可能反弹向上,是短期买入黄金的信号。
在实践中,MACD指标的背离一般出现在强势行情中比较可靠,黄金在高价位时,通常只要出现一次背离的形态即可确认位黄金即将反转,而黄金在低位时,一般要反复出现几次背离后才能确认。因此,MACD指标的顶背离研判的准确性要高于底背离,这点投资者要加以留意。

四、 MACD指标的实战技巧
MACD指标的实战技巧主要集中在MACD指标的“金叉”、“死叉”以及MACD指标中的红、绿柱状线的情况等两大方面。
实践证明,满足"MACD连续二次翻红"往往会有非常好的上涨行情。所谓"MACD连续二次翻红",是指MACD第一次出现红柱后,还没等红柱缩短变绿便又再次放大其红柱。这就是我们在前面讲到的“W底”。如果走势符合这一总则,同时又符合以下四个条件,那就意味着会出现大幅上涨行情的可能性非常大:
一、移动平均线由下跌变为走平或翘头向上,5日、10日、30日移动平均线刚刚形成多头排列;
二、MACD第一次翻红的红柱越短越好;
三、成交量由萎缩逐渐放大;
四、买入后MACD的DIF值必须连续递增;

通达信MACD箭头指标公式

SHORT:=13;LONG:=28;M:=8;
长短期价差:ema(CLOSE,SHORT)-Ema(CLOSE,LONG);
M日均线:EMA(长短期价差,M);
macd:(长短期价差-M日均线)*2,LINETHICK0;

stICKLINE((MacD > 0),0,MACD,2,0),COLOR0000CC;
STICKLINE((MACD > 0),0,MACD*0.9,2,0),COLOR0000EE;
STICKLINE((MACD > 0),0,MACD*0.8,2,0),COLOR0011FF;
STICKLINE((MACD > 0),0,MACD*0.7,MACD指标有什么操作技巧? 2,0),COLOR0033FF;
STICKLINE((MACD > 0),0,MACD*0.6,2,0),COLOR0055FF;
STICKLINE((MACD > 0),0,MACD*0.5,2,0),COLOR0077FF;
STICKLINE((MACD > 0),0,MACD指标有什么操作技巧? MACD*0.4,2,0),COLOR0099FF;
STICKLINE((MACD > 0),0,MACD*0.3,2,0),COLOR00BBFF;
STICKLINE((MACD > 0),MACD指标有什么操作技巧? 0,MACD*0.2,2,0),COLOR00ddfF;
STICKLINE((MACD > 0),0,MACD*0.1,2,0),COLOR00FFFF;
STICKLINE((MACD < 0),0,MACD,2,0),COLORCC0033;
STICKLINE((MACD < 0),0,MACD*0.9,2,0),COLOREE0033;
STICKLINE((MACD < 0),0,MACD*0.8,2,0),COLORFF1133;
STICKLINE((MACD < 0),0,MACD*0.7,2,0),COLORFF3333;
STICKLINE((MACD < 0),0,MACD*0.6,2,0),COLORFF5533;
STICKLINE((MACD < 0),0,MACD*0.5,2,0),COLORFF7733;
STICKLINE((MACD < 0),0,MACD*0.4,2,0),COLORFF9933;
STICKLINE((MACD < 0),0,MACD*0.3,2,0),COLORFFBB33;
STICKLINE((MACD < 0),0,MACD*0.2,2,0),COLORFFDD33;
STICKLINE((MACD < 0),0,MACD*0.1,2,0),COLORFFFF33;
VAR1:=3;
VAR3:=(3)*(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1)) - (2)*(SMA(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1),3,1));
DRAWICON(crOSS(VAR3,VAR1),0,1);

MACD指标有什么操作技巧?

macd.png

MACD称为 指数平滑移动平均线 ,是从双指数移动平均线发展而来的,由快的指数移动平均线(EMA12)减去慢的指数移动平均线(EMA26)得到快线DIF,再用2×(快线DIF-DIF的9日加权移动均线DEA)得到MACD柱。MACD的意义和双移动平均线基本相同,即由快、慢均线的离散、聚合表征当前的多空状态和股价可能的发展变化趋势,但阅读起来更方便。当MACD从负数转向正数,是买的信号。当MACD从正数转向负数,是卖的信号。当MACD以大角度变化,表示快的移动平均线和慢的移动平均线的差距非常迅速的拉开,代表了一个市场大趋势的转变。